PostgreSQL: Konfiguracja klienta

27-Lis-2021

Nie kazdy serwer musi pelnic role  serwera. Zdarzaja sie maszyny, ktore pracuja po prostu jako klient. W przypadku postgresql wymagane bedzie wtedy zainstalowanie narzedzi klienckich.

Swietnie sie zapowiadajace polcenie:

moze jednak sprawic niespodzianke. Po probie polaczenia mozna otrzymac blad:

Error: You must install at least one postgresql-client-<version> package

O co chodzi? Ten pakiet zawiera tylko linki do innych juz wczesniej zainstalowanych binariow. Pewnie fajnie sie sprawdzi, jesli na danym serwerze bylo by zainstalowanych kilka clustrow postgresql, a ty pracujac z nimi preferujesz wybrac tylko jedna wersje klienta. Ale my na poczatku zalozylismy, ze system jest „goly” – nie ma na nim postgresql server. Co zrobic? Trzeba samodzielnie zdecydowac sie na wersje, ktora bedzie wykorzystywana i uruchomic np.:

Teraz mozna juz bedzie polaczyc sie do postgresql:

https://stackoverflow.com/questions/28290488/get-error-you-must-install-at-least-one-postgresql-client-version-package-whe

Dodaj komentarz:

Autor: Rafał Kraik