Błąd podczas kompilacji php „xml2-config not found”

14-Paź-2011

Podczas instalacji PHP v5  wystąpił błąd po uruchomieniu polecenia ./configure:

configure: error: xml2-config not found. Please check your libxml2 installation.

Co ciekawe biblioteka xml-2 była już zainstalowana.

Jeżeli jednak planujesz dokonywać kompilacji w oparciu o inne pakiety, to często okaże się, że tak na prawdę potrzebny jest pakied *-devel, w tym przypadku libxml2-devel.

Ponieważ instalacja miała miejsce na SuSE,  wystarczyło uruchomić yast, doinstalować pakiet devel, a potem już zająć się kompilacją.

Dodaj komentarz:

Autor: Rafał Kraik